1С ЗЛУЧЭННІ ЗАКРЫТО сервера

Апрацоўка рассылання печ.форм выкарыстоўвалася ў іншай інфармацыйнай базе ў кліент-сервернае варыянце, цяпер яе скапіявалі ў новую инф.базу якая працуе ў файлавым варыянце, пры выкліку працэдуры адправіць па пошце выдае паведамленне:

Не атрымалася адправіць паведамленне контрагенту: «Гр, СПН» + па адрасе: «[email protected]» па прычыне: {ВнешняяОбработка.ФормированиеДокументовЭл.МодульОбъекта (1143)}:

Памылка пры выкліку метаду кантэксту (Паслаць): Памылка пры выкананні файлавай аперацыі: Сувязь спынена серверам.

дапамажыце зразумець у якім месцы ў кодзе трэба падправіць, каб апрацоўка зарабіла, бо на старой базе яна нармальна працуе

код:

Працэдура ОтправитьПисьмо (Контрагент, АдресПолучателя, МассивФайлов) Экспарт

ИнтернетПочта = Новы ИнтернетПочта;

ПочтовыйПрофиль = Новы ИнтернетПочтовыйПрофиль;

ПочтовыйПрофиль.АдресСервераPOP3 = «83.243.64.1»;

ПочтовыйПрофиль.АдресСервераSMTP = «83.243.64.1»;

ПочтовыйПрофиль.ПортPOP3 = 110;

ПочтовыйПрофиль.ПортSMTP = 25;

ПочтовыйПрофиль.Пользователь = «[email protected]»;

ПочтовыйПрофиль.Пароль = «xx»;

ПочтовыйПрофиль.ПользовательSMTP = «[email protected]»;

ПочтовыйПрофиль.ПарольSMTP = «xx»;

ПочтовыйПрофиль.АутентификацияSMTP = СпособSMTPАутентификации.Login;

ИнтернетСообщение = Новы ИнтернетПочтовоеСообщение;

ИнтернетСообщение.Кодировка = «windows-1251»;

ИнтернетСообщение.Тема = «Аўтаматычная рассыланне Эл»;

ИнтернетСообщение.ИмяОтправителя = «Цэнтр друку рахункаў ЭТ»;

ИнтернетСообщение.Отправитель = «[email protected]»;

Рэшту = СтрЗаменить (СокрЛП (АдресПолучателя), "", "");

Калі Знайсці (Рэшта, «,»)> 0 Тады

Пакуль Знайсці (Рэшта, «,»)> 0 Цыкл

да = Знайсці (Рэшта, «,»);

_темп = Леў (Рэшта, да - 1);

ИнтернетСообщение.Получатели.Добавить (_темп);

Рэшту = Правоў (рэшту, СтрДлина (рэшту) - к);

КонецЦикла;

Інакш

ИнтернетСообщение.Получатели.Добавить (Рэшта);

КонецЕсли;

ИнтернетСообщение.Тексты.Добавить (ТекстПисьма, ТипТекстаПочтовогоСообщения.ПростойТекст);

Для кожнага Файл З МассивФайлов Цыкл

ИнтернетСообщение.Вложения.Добавить (Файл);

КонецЦикла;

всеПлохо = Хлусня;

Спроба

ИнтернетПочта.Подключиться (ПочтовыйПрофиль);

ИнтернетПочта.Послать (ИнтернетСообщение);

Выключэнне

Паведаміць ( «не дасланае контрагенту:« »» + Контрагент + «» »+ па адрасе:« »» + АдресПолучателя + «» »па прычыне:» + ОписаниеОшибки (), СтатусСообщения.Важное);

всеПлохо = Ісціна;

КонецПопытки;

Калі Ня всеПлохо Тады

Паведаміць ( «Ліст адпраўлена на адрас эл. Пошты:» + АдресПолучателя);

КонецЕсли;

КонецПроцедуры

Чытай на іншых мовах

 беларускіанглійская Нямецкі іспанскі французскі італьянскі партугальская турэцкі арабская ўкраінскі шведскі венгерская балгарскі эстонскі Кітайскі (спрошчаны) в'етнамская румынская тайская славенская славацкая сербская малайская нарвежская латышская Літоўскі карэйская японскі інданезійская хіндзі іўрыт фінскі грэцкі нідэрландская чэшскі дацкая харвацкая Кітайскі (традыцыйны) тагальская урду Азейбарджанский армянскіпольскі бенгальская грузінскі казахскі каталонская Mongolski руская Таджитский Tamil'skij тэлугу Узбецкий

Чытай яшчэ:   ЯК ЗАХАВАЦЬ GOOGLE MAPS OFFLINE

дадаць каментар

Ваш e-mail не будзе апублікаваны. Абавязковыя палі пазначаныя *